Beagle USB 480 Power Protocol Analyzer Quick Start Guide

Introduction

These getting-started guidelines are intended to facilitate the first use of the Beagle USB 480 Power Protocol Analyzer. The Beagle USB 480 Power analyzer can be used with the Data Center Software or the Beagle Software API to monitor Low, Full, or High-Speed USB 2.0 (up to 480 Mbps) devices. This tool also monitors and graphs VBUS current and voltage values in real time. Use the Beagle USB 480 Power analyzer with the Data Center Software and follow the instructions below to monitor a USB 2.0 device.

All current downloads for the Beagle USB 480 Power analyzer can be found on the product page:

 

Getting Started Guidelines

  1. Download and run the latest version of the Total Phase USB Drivers Installer. {USB Drivers - Linux} {USB Drivers - Windows}
  2. Connect the Beagle analyzer analysis port to the computer. (?)
  3. Download and unzip the latest version of Data Center Software; select from Windows, Linux, or Mac(?)
  4. Launch the Data Center Software. (?)
  5. Connect to the Beagle Analyzer. (?)
    1. Click Analyzer > Connect to Analyzer.
    2. Select the Beagle analyzer.

    3. Click OK to connect to the Beagle analyzer.
  6. Configure the Device Settings for High-speed USB 2.0. (?)
    1. Click Analyzer > Device Settings.
    2. Choose USB in the Capture Protocol option.

    3. Configure the USB 2.0 Bus Speed to Auto detect.
    4. The Current/Voltage Monitor feature will be automatically enabled. To disable, uncheck the Enable VBUS Current/Voltage Monitor box.
    5. For the Ultimate edition, optionally input settings for VBUS Trigger Threshold for Complex Matching that allows users to trigger on a rise or drop in VBUS current or voltage.
    6. Click OK to close the Device Settings.
  7. Configure the Capture Settings. (?)
    1. Click Analyzer > Capture Settings.
    2. Choose USB tab.

    3. Optionally configure the Capture Mode to Sequential.
    4. Optionally enable keeping Data-less Sequences for USB 2.0.
    5. Choose General tab.

    6. Change the Capture Data Limit size to the desired amount.
    7. Click OK to close the Capture Settings.
  8. Configure Current/Voltage Monitor. (?)
    1. Click View > Current/Voltage Monitor.
    2. Optionally reposition Current/Voltage Monitor window within the software.

  9. Start the capture. (?)
    1. Click Analyzer > Run Capture.
  10. Connect the Beagle analyzer's target host ports to the target host and target device (?)
    1. Valid configurations are shown in the Beagle user manual.

  11. The Capture Started record will be displayed in the Transaction window along with any data captured from the bus.

  12. Stop the capture. (?)
    1. Click Analyzer > Stop Capture.
  13. Save or export the capture.
    1. Click File > Save to save the capture as a TDC file. (?)

    2. Click File > Export to export the capture as a CSV file. (?)

Notes

For additional information, take a look at the Beagle analyzer user manual, and Data Center manual.

For a video demonstration of this tool in action, please visit Monitor VBUS Current and Voltage with the Beagle USB 480 Power Protocol Analyzer.