Compatibility between newer Aardvark FW and older SW (FW >= 3.40) – Total Phase
Compatibility between newer Aardvark FW and older SW (FW >= 3.40)

Newer Aardvark I2C/SPI Host Adapters with firmware version 3.40 or higher are compatible with older versions of the Aardvark software. However, there is one minor incompatibility that will require an upgrade of the software. This incompatibility only affects using the Aardvark adapter as an I2C master and reading from a slave that has a 10-bit address. If you are using the Aardvark adapter in this situation, and the Aardvark has firmware version 3.40 or higher, Total Phase recommends you use the current version of the software API and shared library.

Have more questions? Submit a request